<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />

	<!-- This site is optimized with the Yoast SEO plugin v14.0.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Outdoor shooting ranges open to public - Michigan United Conservation Clubs</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://mucc.org/outdoor-shooting-ranges-now-open-to-public/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Outdoor shooting ranges open to public - Michigan United Conservation Clubs" />
	<meta property="og:description" content="Outdoor shooting ranges in Michigan were allowed to open their doors to the public this week per one of the governor’s newest executive orders.  MUCC has been working on reopening outdoor ranges to the public since the beginning of the “Stay Home, Stay Safe” executive orders, including writing a letter to the governor’s office and&hellip;" />
	<meta property="og:url" content="https://mucc.org/outdoor-shooting-ranges-now-open-to-public/" />
	<meta property="og:site_name" content="Michigan United Conservation Clubs" />
	<meta property="article:published_time" content="2020-05-08T18:19:56+00:00" />
	<meta property="article:modified_time" content="2020-05-08T18:22:15+00:00" />
	<meta property="og:image" content="https://mucc.org/wp-content/uploads/2020/05/047A6475-1-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="1707" />
	<meta name="twitter:card" content="summary" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://mucc.org/#website","url":"https://mucc.org/","name":"Michigan United Conservation Clubs","description":"The largest statewide conservation organization in Michigan. Its mission is to unite citizens to conserve, protect and enhance Michigan\u2019s natural resources and outdoor heritage.","potentialAction":[{"@type":"SearchAction","target":"https://mucc.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mucc.org/outdoor-shooting-ranges-now-open-to-public/#primaryimage","inLanguage":"en-US","url":"https://mucc.org/wp-content/uploads/2020/05/047A6475-1-scaled.jpg","width":2560,"height":1707},{"@type":"WebPage","@id":"https://mucc.org/outdoor-shooting-ranges-now-open-to-public/#webpage","url":"https://mucc.org/outdoor-shooting-ranges-now-open-to-public/","name":"Outdoor shooting ranges open to public - Michigan United Conservation Clubs","isPartOf":{"@id":"https://mucc.org/#website"},"primaryImageOfPage":{"@id":"https://mucc.org/outdoor-shooting-ranges-now-open-to-public/#primaryimage"},"datePublished":"2020-05-08T18:19:56+00:00","dateModified":"2020-05-08T18:22:15+00:00","author":{"@id":"https://mucc.org/#/schema/person/737bd56a9a30918e2a35e2d32ce9ded0"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mucc.org/outdoor-shooting-ranges-now-open-to-public/"]}]},{"@type":["Person"],"@id":"https://mucc.org/#/schema/person/737bd56a9a30918e2a35e2d32ce9ded0","name":"Nick Green","image":{"@type":"ImageObject","@id":"https://mucc.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/655e7da6eafadc0f9a3930c9853957f1?s=96&d=mm&r=g","caption":"Nick Green"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Michigan United Conservation Clubs &raquo; Feed" href="https://mucc.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Michigan United Conservation Clubs &raquo; Comments Feed" href="https://mucc.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Michigan United Conservation Clubs &raquo; Outdoor shooting ranges open to public Comments Feed" href="https://mucc.org/outdoor-shooting-ranges-now-open-to-public/feed/" />
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mucc.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://mucc.org/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://mucc.org/wp-includes/css/dist/block-library/theme.min.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='inspire-events-css'  href='https://mucc.org/wp-content/plugins/inspire-events/includes/css/main.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://mucc.org/wp-content/plugins/inspire-events/includes/css/jquery-ui/inspire/jquery-ui.min.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='jquery-ui-theme-css'  href='https://mucc.org/wp-content/plugins/inspire-events/includes/css/jquery-ui/inspire/theme.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://mucc.org/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.min.css?ver=2.3.2.5' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://mucc.org/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.7.6.2' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://mucc.org/wp-content/uploads/bb-theme/skin-5eb32440b3739.css?ver=1.7.6.2' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-ddcbcc9b9cf09a4823bb0c04322c316d-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.4.1' media='all' />
<script src='https://mucc.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://mucc.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/selectmenu.min.js?ver=1.11.4'></script>
<script>
var NIE = {"ajaxurl":"https:\/\/mucc.org\/wp-admin\/admin-ajax.php","firstDay":"1","nie_theme":"1","nie_limit":"3","nie_limit_txt":"more ...","timeFormat":"h(:mm)A","defaultView":"month","weekends":"true","header":{"left":"prev,next today","center":"title","right":"month,basicWeek,basicDay"},"nie_qtips":"1","nie_qtips_classes":"ui-tooltip-light ui-tooltip-shadow","nie_qtips_my":"top center","nie_qtips_at":"bottom center"};
</script>
<script src='https://mucc.org/wp-content/plugins/inspire-events/includes/js/main.js?ver=1.1.0'></script>
<link rel='https://api.w.org/' href='https://mucc.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mucc.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mucc.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://mucc.org/?p=8157' />
<link rel="alternate" type="application/json+oembed" href="https://mucc.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmucc.org%2Foutdoor-shooting-ranges-now-open-to-public%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mucc.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmucc.org%2Foutdoor-shooting-ranges-now-open-to-public%2F&#038;format=xml" />
<link rel="pingback" href="https://mucc.org/xmlrpc.php">
<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-32x32.png" sizes="32x32" />
<link rel="icon" href="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-180x180.png" />
<meta name="msapplication-TileImage" content="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-270x270.png" />
		<style id="wp-custom-css">
			@media (min-width: 600px) { 
    .neon_C_content .neoncrm-three-column .neoncrm-product-list-product { 
        width: 31%;
    }
    .neon_C_content .neoncrm-product-list.neoncrm-three-column { 
        text-align: center;
    } 
}

/*
CSS Migrated from BB theme:
*/

.z2shadow {
    text-shadow: 1px 1px #000000;   
}		</style>
		<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.3.1/css/all.css" integrity="sha384-mzrmE5qonljUremFsqc01SB46JvROS7bZs3IO2EmfFsd15uHvIt+Y8vEf7N7fWAU" crossorigin="anonymous">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.8.1/css/all.css">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.8.1/css/v4-shims.css">
<link rel="stylesheet" href="https://mucc.org/wp-content/themes/bb-inspire/style.css" /></head>
<body class="post-template-default single single-post postid-8157 single-format-standard fl-framework-bootstrap fl-preset-agloe-nature fl-full-width fl-has-sidebar fl-footer-effect fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div class="fl-page">
	<header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile"  role="banner">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-sm-12 col-md-3 fl-page-logo-wrap">
					<div class="fl-page-header-logo">
						<a href="https://mucc.org/"><img data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://mucc.org/wp-content/uploads/2017/10/wordmarkResized-1.png" data-retina="" title="" alt="Michigan United Conservation Clubs" /><meta itemprop="name" content="Michigan United Conservation Clubs" /></a>
					</div>
				</div>
				<div class="col-sm-12 col-md-9 fl-page-fixed-nav-wrap">
					<div class="fl-page-nav-wrap">
						<nav class="fl-page-nav fl-nav navbar navbar-default navbar-expand-md" aria-label="Header Menu" role="navigation">
							<button type="button" class="navbar-toggle navbar-toggler" data-toggle="collapse" data-target=".fl-page-nav-collapse">
								<span>Menu</span>
							</button>
							<div class="fl-page-nav-collapse collapse navbar-collapse">
								<ul id="menu-main-navigation" class="nav navbar-nav navbar-right menu fl-theme-menu"><li id="menu-item-1659" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1659 nav-item"><a href="https://mucc.org/about-us/" class="nav-link">About</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1670" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1670 nav-item"><a href="https://mucc.org/blog/" class="nav-link">Blog</a></li>
	<li id="menu-item-1675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1675 nav-item"><a href="https://mucc.org/financials/" class="nav-link">Membership</a></li>
	<li id="menu-item-1674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1674 nav-item"><a href="https://mucc.org/contact/" class="nav-link">Partners</a></li>
	<li id="menu-item-7231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7231 nav-item"><a href="https://p2a.co/xnhf8XJ" class="nav-link">Policy Action Center</a></li>
	<li id="menu-item-1672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1672 nav-item"><a href="https://mucc.org/staff/" class="nav-link">Staff</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
	<ul class="sub-menu">
		<li id="menu-item-5117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5117 nav-item"><a href="https://mucc.org/staff/careers/" class="nav-link">Careers</a></li>
	</ul>
</li>
	<li id="menu-item-1671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1671 nav-item"><a href="https://mucc.org/board/" class="nav-link">Board of Directors</a></li>
	<li id="menu-item-1673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1673 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/eventList.jsp" class="nav-link">Calendar</a></li>
	<li id="menu-item-4561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4561 nav-item"><a href="https://mucc.org/about-us/economic-impact-study-2019/" class="nav-link">Economic Impact Study 2019</a></li>
	<li id="menu-item-5116" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5116 nav-item"><a href="https://mucc.org/affiliated-clubs/" class="nav-link">Affiliated Clubs</a></li>
</ul>
</li>
<li id="menu-item-1660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1660 nav-item"><a href="https://mucc.org/events/" class="nav-link">Events</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1677" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1677 nav-item"><a href="https://mucc.org/mucc-annual-convention/" class="nav-link">MUCC Annual Convention</a></li>
	<li id="menu-item-1676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1676 nav-item"><a href="https://mucc.org/annual-charity-shoot/" class="nav-link">Annual Charity Shoot</a></li>
</ul>
</li>
<li id="menu-item-1661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1661 nav-item"><a href="https://mucc.org/programs/" class="nav-link">Programs</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1680" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1680 nav-item"><a href="https://mucc.org/on-the-ground/" class="nav-link">ON THE GROUND</a></li>
	<li id="menu-item-6028" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6028 nav-item"><a href="https://mucc.org/on-the-water/" class="nav-link">On The Water</a></li>
	<li id="menu-item-2512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2512 nav-item"><a href="http://www.mucccamp.org/" class="nav-link">Youth Camp</a></li>
	<li id="menu-item-1679" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1679 nav-item"><a href="https://mucc.org/cooperatives/" class="nav-link">Michigan Wildlife Cooperatives</a></li>
</ul>
</li>
<li id="menu-item-1666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1666 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Support</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1684 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC: become a member</a></li>
	<li id="menu-item-1687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1687 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Donate</a></li>
	<li id="menu-item-1683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1683 nav-item"><a href="https://mucc.org/conservation-insider-2/" class="nav-link">Conservation Insider</a></li>
	<li id="menu-item-1685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1685 nav-item"><a href="https://mucc.org/sweepstakes/" class="nav-link">SWEEPSTAKES</a></li>
</ul>
</li>
<li id="menu-item-1662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1662 nav-item"><a href="https://mucc.org/about/" class="nav-link">Media</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1664" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1664 nav-item"><a href="https://mucc.org/post-239/" class="nav-link">Michigan Out-of-Doors</a></li>
	<li id="menu-item-1665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1665 nav-item"><a href="https://mucc.org/video/" class="nav-link">Video</a></li>
</ul>
</li>
<li id="menu-item-1688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1688 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/giftstore.jsp" class="nav-link">Online Store</a></li>
<li id="menu-item-1663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC</a></li>
</ul>							</div>
						</nav>
					</div>
				</div>
			</div>
		</div>
	</div>
</header><!-- .fl-page-header-fixed -->
<div class="fl-page-bar">
	<div class="fl-page-bar-container container">
		<div class="fl-page-bar-row row">
			<div class="col-sm-6 col-md-6 text-left clearfix">	<div class="fl-social-icons">
	<a href="https://www.facebook.com/mucc1937/" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="https://twitter.com/MIOutofDoors" target="_blank" rel="noopener noreferrer"><span class="sr-only">Twitter</span><i aria-hidden="true" class="fab fa-twitter mono"></i></a><a href="www.youtube.com" target="_blank" rel="noopener noreferrer"><span class="sr-only">Youtube</span><i aria-hidden="true" class="fab fa-youtube mono"></i></a></div>
</div>			<div class="col-sm-6 col-md-6 text-right clearfix">		<nav class="top-bar-nav" aria-label="Top Bar Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" role="navigation">
			<ul id="menu-navigation" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-1667" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1667 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Donate</a></li>
<li id="menu-item-1690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1690 nav-item"><a href="https://mucc.org/about/" class="nav-link">Become a Member</a></li>
<li id="menu-item-1669" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1669 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/login.jsp" class="nav-link">Log In</a></li>
</ul></nav></div>		</div>
	</div>
</div><!-- .fl-page-bar -->
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader"  role="banner">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-md-12 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://mucc.org/" itemprop="url"><img data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://mucc.org/wp-content/uploads/2017/10/wordmarkResized-1.png" data-retina="" title="" alt="Michigan United Conservation Clubs" /><meta itemprop="name" content="Michigan United Conservation Clubs" /></a>
											</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav fl-nav navbar navbar-default navbar-expand-md" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" role="navigation">
				<button type="button" class="navbar-toggle navbar-toggler" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span>Menu</span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-main-navigation-1" class="nav navbar-nav menu fl-theme-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1659 nav-item"><a href="https://mucc.org/about-us/" class="nav-link">About</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1670 nav-item"><a href="https://mucc.org/blog/" class="nav-link">Blog</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1675 nav-item"><a href="https://mucc.org/financials/" class="nav-link">Membership</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1674 nav-item"><a href="https://mucc.org/contact/" class="nav-link">Partners</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7231 nav-item"><a href="https://p2a.co/xnhf8XJ" class="nav-link">Policy Action Center</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1672 nav-item"><a href="https://mucc.org/staff/" class="nav-link">Staff</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5117 nav-item"><a href="https://mucc.org/staff/careers/" class="nav-link">Careers</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1671 nav-item"><a href="https://mucc.org/board/" class="nav-link">Board of Directors</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1673 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/eventList.jsp" class="nav-link">Calendar</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4561 nav-item"><a href="https://mucc.org/about-us/economic-impact-study-2019/" class="nav-link">Economic Impact Study 2019</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5116 nav-item"><a href="https://mucc.org/affiliated-clubs/" class="nav-link">Affiliated Clubs</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1660 nav-item"><a href="https://mucc.org/events/" class="nav-link">Events</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1677 nav-item"><a href="https://mucc.org/mucc-annual-convention/" class="nav-link">MUCC Annual Convention</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1676 nav-item"><a href="https://mucc.org/annual-charity-shoot/" class="nav-link">Annual Charity Shoot</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1661 nav-item"><a href="https://mucc.org/programs/" class="nav-link">Programs</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1680 nav-item"><a href="https://mucc.org/on-the-ground/" class="nav-link">ON THE GROUND</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6028 nav-item"><a href="https://mucc.org/on-the-water/" class="nav-link">On The Water</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2512 nav-item"><a href="http://www.mucccamp.org/" class="nav-link">Youth Camp</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1679 nav-item"><a href="https://mucc.org/cooperatives/" class="nav-link">Michigan Wildlife Cooperatives</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1666 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Support</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1684 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC: become a member</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1687 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Donate</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1683 nav-item"><a href="https://mucc.org/conservation-insider-2/" class="nav-link">Conservation Insider</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1685 nav-item"><a href="https://mucc.org/sweepstakes/" class="nav-link">SWEEPSTAKES</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1662 nav-item"><a href="https://mucc.org/about/" class="nav-link">Media</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1664 nav-item"><a href="https://mucc.org/post-239/" class="nav-link">Michigan Out-of-Doors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1665 nav-item"><a href="https://mucc.org/video/" class="nav-link">Video</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1688 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/giftstore.jsp" class="nav-link">Online Store</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC</a></li>
</ul><div class="fl-page-nav-search">
	<a href="javascript:void(0);" class="fas fa-search" aria-label="Search" aria-expanded="false" aria-haspopup="true" id='flsearchform'></a>
	<form method="get" role="search" aria-label="Search" action="https://mucc.org/" title="Type and press Enter to search.">
		<input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" aria-labelledby="flsearchform" />
	</form>
</div>
				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div id="fl-main-content" class="fl-page-content" itemprop="mainContentOfPage" role="main">

		
<div class="container">
	<div class="row">

		
		<div class="fl-content fl-content-left col-md-9">
			<article class="fl-post post-8157 post type-post status-publish format-standard has-post-thumbnail hentry category-policy tag-michigan tag-michigan-gun-ranges tag-michigan-shooting-ranges tag-shooting-ranges" id="fl-post-8157" itemscope itemtype="https://schema.org/BlogPosting">

					<div class="fl-post-thumb">
			<img width="1024" height="683" src="https://mucc.org/wp-content/uploads/2020/05/047A6475-1-1024x683.jpg" class="attachment-large size-large wp-post-image" alt="" itemprop="image" srcset="https://mucc.org/wp-content/uploads/2020/05/047A6475-1-1024x683.jpg 1024w, https://mucc.org/wp-content/uploads/2020/05/047A6475-1-300x200.jpg 300w, https://mucc.org/wp-content/uploads/2020/05/047A6475-1-768x512.jpg 768w, https://mucc.org/wp-content/uploads/2020/05/047A6475-1-1536x1024.jpg 1536w, https://mucc.org/wp-content/uploads/2020/05/047A6475-1-2048x1365.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" />		</div>
			
	<header class="fl-post-header" role="banner">
		<h1 class="fl-post-title" itemprop="headline">
			Outdoor shooting ranges open to public					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://mucc.org/author/ngreen/"><span>Nick Green</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date">May 8, 2020</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://mucc.org/outdoor-shooting-ranges-now-open-to-public/#respond" tabindex="-1" aria-hidden="true"><span aria-label="Comments: 0">0 <i aria-hidden="true" class="fas fa-comment"></i></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://mucc.org/outdoor-shooting-ranges-now-open-to-public/" content="Outdoor shooting ranges open to public" /><meta itemprop="datePublished" content="2020-05-08" /><meta itemprop="dateModified" content="2020-05-08" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Michigan United Conservation Clubs"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mucc.org/wp-content/uploads/2017/10/wordmarkResized-1.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://mucc.org/author/ngreen/" /><meta itemprop="name" content="Nick Green" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mucc.org/wp-content/uploads/2020/05/047A6475-1-scaled.jpg" /><meta itemprop="width" content="2560" /><meta itemprop="height" content="1707" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

			
			
	
	<div class="fl-post-content clearfix" itemprop="text">
		<p><span style="font-weight: 400;">Outdoor shooting ranges in Michigan were allowed to open their doors to the public this week per one of the governor’s newest executive orders. </span></p>
<p><span style="font-weight: 400;">MUCC has been working on reopening outdoor ranges to the public since the beginning of the “Stay Home, Stay Safe” executive orders, including writing a </span><a href="https://mucc.org/wp-content/uploads/2020/04/04.29.2020-Shooting-Ranges.pdf"><span style="font-weight: 400;">letter</span></a><span style="font-weight: 400;"> to the governor’s office and legislative leaders. Shooting ranges are a vital part of many MUCC-affiliated clubs, and MUCC heard from members across the state about the closure’s financial impact on their respective clubs.</span></p>
<p><span style="font-weight: 400;">Gov. Gretchen Whitmer enacted </span><a href="https://www.michigan.gov/whitmer/0,9309,7-387-90499_90705-528460--,00.html"><span style="font-weight: 400;">Executive Order 2020-77</span></a><span style="font-weight: 400;"> on May 7, which allows, under section 10 (e), outdoor workers to resume operations under certain precautionary guidelines:</span></p>
<p style="padding-left: 40px;"><em><span style="font-weight: 400;">For purposes of this order, workers who perform resumed activities are defined as follows:</span></em></p>
<p style="padding-left: 40px;"><em><span style="font-weight: 400;">Subject to the enhanced social-distancing rules described in section 11(i) of this order, workers who perform work that is traditionally and primarily performed outdoors, including but not limited to forestry workers, outdoor power equipment technicians, parking enforcement workers,</span><b> and outdoor workers at places of outdoor recreation </b><span style="font-weight: 400;">not otherwise closed under Executive Order 2020-69 or any order that may follow from it.</span></em></p>
<p><span style="font-weight: 400;">The newest order also allows, under section 7 (a)(1),  for the public to recreate outdoors in a safe manner, including outdoor shooting ranges: </span></p>
<p style="padding-left: 40px;"><em><span style="font-weight: 400;">Individuals may leave their home or place of residence, and travel as necessary:</span><span style="font-weight: 400;">To engage in outdoor recreational activity, consistent with remaining at least six feet from people from outside the individual’s household. Outdoor recreational activity includes walking, hiking, running, cycling, boating, golfing, or other similar activity, as well as any comparable activity for those with limited mobility.</span></em></p>
<p><span style="font-weight: 400;">MUCC Executive Director Amy Trotter said shooting ranges have been losing significant revenue, and some have even considered closing their doors, as a result of the range closures.</span></p>
<p><span style="font-weight: 400;">“Many of MUCC’s affiliate clubs have been taking immense financial hits during this time” Trotter said. “Getting Michiganders reengaged with our outdoor spaces is a step in the right direction, and our clubs are eager to safely resume operations.”</span></p>
<p><span style="font-weight: 400;">Outdoor shooting ranges will still be subject to certain guidelines during operation outlined below:</span></p>
<ul>
<li style="font-weight: 400;"><span style="font-weight: 400;">All customers and employees/volunteer workers must remain 6 feet apart from each other if they do not reside in the same household. </span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">No indoor accommodations may be available to access for lounging, seating or other activities, such as clubhouses, indoor ranges, bars or restaurants. Take out food is allowed to be sold if in compliance with </span><a href="https://www.michigan.gov/whitmer/0,9309,7-387-90499_90705-527830--,00.html"><span style="font-weight: 400;">EO 2020-69</span></a><span style="font-weight: 400;">. </span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Range or membership fees are encouraged to be accepted via phone, online or dropbox to the extent possible. Personal firearms, cases, and other gear from home should not be brought into the clubhouse and masks should be worn indoors. </span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Provide or require workers/volunteers personal protective equipment such as gloves, goggles, face shields, and face masks as appropriate for the activity being performed. </span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Adopt protocols to limit the sharing of tools and equipment to the maximum extent possible and to ensure frequent and thorough cleaning of tools, equipment, and frequently touched surfaces, especially including restrooms. No rental equipment should be provided. </span></li>
</ul>
<p><span style="font-weight: 400;">Since 1937, MUCC has united citizens to conserve, protect and enhance Michigan&#8217;s natural resources and outdoor heritage. MUCC has also been the constant protector of your rights to hunt, fish and trap since its founding. Consider joining us today: </span><a href="https://bit.ly/JoinMUCC?fbclid=IwAR0GISmTYPhaXcuqIjq3RIcie3YyLWfjmNDWqEw28xKiQuzRBjvJURCnDxM"><span style="font-weight: 400;">http://bit.ly/JoinMUCC</span></a></p>
	</div><!-- .fl-post-content -->

	
	<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://mucc.org/category/policy/" rel="category tag">Policy</a> and tagged <a href="https://mucc.org/tag/michigan/" rel="tag">michigan</a>, <a href="https://mucc.org/tag/michigan-gun-ranges/" rel="tag">michigan gun ranges</a>, <a href="https://mucc.org/tag/michigan-shooting-ranges/" rel="tag">michigan shooting ranges</a>, <a href="https://mucc.org/tag/shooting-ranges/" rel="tag">shooting ranges</a></div></div>	<div class="fl-post-nav clearfix"><span class="fl-post-nav-prev"><a href="https://mucc.org/michigan-out-of-doors-youth-camp-2020-summer-programs-cancelled/" rel="prev">&larr; 2020 Michigan Out-of-Doors Youth Camp Summer Programs Cancelled</a></span></div>	<div class="fl-author-box">
	<div class="fl-author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/655e7da6eafadc0f9a3930c9853957f1?s=68&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/655e7da6eafadc0f9a3930c9853957f1?s=136&#038;d=mm&#038;r=g 2x' class='avatar avatar-68 photo' height='68' width='68' />	</div> <!-- /.author-avatar -->
	<div class="fl-author-description">
				<h4>About Nick Green</h4>
		<p></p>
		<div class="fl-author-link">
			<a href="https://mucc.org/author/ngreen/" rel="author">
				View all posts by Nick Green <span class="meta-nav">&rarr;</span>			</a>
		</div> <!-- /.author-link	-->
	</div> <!-- /.author-description -->
</div> <!-- /.author-info -->

</article>
<div class="fl-comments">

	
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/outdoor-shooting-ranges-now-open-to-public/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://mucc.org/wp-comments-post.php" method="post" id="fl-comment-form" class="fl-comment-form"><label for="fl-comment">Comment</label><textarea id="fl-comment" name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea><br /><label for="fl-author">Name (required)</label>
									<input type="text" id="fl-author" name="author" class="form-control" value="" tabindex="1" aria-required="true" /><br />
<label for="fl-email">Email (will not be published) (required)</label>
									<input type="text" id="fl-email" name="email" class="form-control" value="" tabindex="2" aria-required="true" /><br />
<label for="fl-url">Website</label>
									<input type="text" id="fl-url" name="url" class="form-control" value="" tabindex="3" /><br />
<p class="form-submit"><input name="submit" type="submit" id="fl-comment-form-submit" class="btn btn-primary" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='8157' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cd376cecd0" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="206"/></p></form>	</div><!-- #respond -->
		</div>


<!-- .fl-post -->
		</div>

		<div class="fl-sidebar fl-sidebar-right fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
			</div>

	</div>
</div>

			
	</div><!-- .fl-page-content -->
		<footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		<div class="fl-page-footer">
	<div class="fl-page-footer-container container">
		<div class="fl-page-footer-row row">
			<div class="col-sm-6 col-md-6 text-left clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">Michigan United Conservation Clubs, a 501c3 nonprofit conservation organization <br>
2101 Wood St. <br>
Lansing, MI 48912<br>
517.371.1041</div></div>			<div class="col-sm-6 col-md-6 text-right clearfix">	<div class="fl-social-icons">
	<a href="https://www.facebook.com/mucc1937/" class="fa-stack icon-facebook-f" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span>
					<i aria-hidden="true" class="fas fa-circle fa-stack-2x mono"></i>
					<i aria-hidden="true" class="fab fa-facebook-f mono fa-stack-1x fa-inverse"></i>
					</a><a href="https://twitter.com/MIOutofDoors" class="fa-stack icon-twitter" target="_blank" rel="noopener noreferrer"><span class="sr-only">Twitter</span>
					<i aria-hidden="true" class="fas fa-circle fa-stack-2x mono"></i>
					<i aria-hidden="true" class="fab fa-twitter mono fa-stack-1x fa-inverse"></i>
					</a><a href="www.youtube.com" class="fa-stack icon-youtube" target="_blank" rel="noopener noreferrer"><span class="sr-only">Youtube</span>
					<i aria-hidden="true" class="fas fa-circle fa-stack-2x mono"></i>
					<i aria-hidden="true" class="fab fa-youtube mono fa-stack-1x fa-inverse"></i>
					</a></div>
</div>		</div>
	</div>
</div><!-- .fl-page-footer -->
		<div style="font-size: 11px; text-align: center; padding: 10px 0; opacity: 0.7;">
			Website powered by <a target="_blank" href="https://www.neoncrm.com/websites">Neon Inspire</a>
		</div>
	</footer>
		</div><!-- .fl-page -->
<link rel='stylesheet' id='font-awesome-5-css'  href='https://mucc.org/wp-content/plugins/bb-plugin/fonts/fontawesome/5.13.0/css/all.min.css?ver=2.3.2.5' media='all' />
<script>
var google_analytics = {"code":"UA-6089463-1","internal_code":"UA-103910486-15"};
</script>
<script src='https://mucc.org/wp-content/plugins/neoncrm-suite/js/neon-google-analytics.js?ver=5.4.1'></script>
<script>
var neoncrm_email_ajax_object = {"ajax_url":"https:\/\/mucc.org\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://mucc.org/wp-content/plugins/neoncrm-suite/js/neon-email-signup.js?ver=5.4.1'></script>
<script src='https://mucc.org/wp-content/plugins/bb-plugin/js/jquery.ba-throttle-debounce.min.js?ver=2.3.2.5'></script>
<script src='https://mucc.org/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=2.3.2.5'></script>
<script src='https://mucc.org/wp-content/plugins/bb-plugin/js/jquery.fitvids.min.js?ver=1.2'></script>
<script src='https://mucc.org/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script src='https://mucc.org/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.7.6.2'></script>
<script>
var themeopts = {"medium_breakpoint":"992","mobile_breakpoint":"768"};
</script>
<script src='https://mucc.org/wp-content/themes/bb-theme/js/theme.min.js?ver=1.7.6.2'></script>
<script src='https://mucc.org/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script async="async" src='https://mucc.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
</body>
</html>
<!-- Dynamic page generated in 1.640 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-05-09 11:05:21 -->

<!-- super cache -->