<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />

	<!-- This site is optimized with the Yoast SEO plugin v14.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>U.S. Senate Passes Monumental Public Lands Package - Michigan United Conservation Clubs</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://mucc.org/u-s-senate-passes-monumental-public-lands-package/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="U.S. Senate Passes Monumental Public Lands Package - Michigan United Conservation Clubs" />
	<meta property="og:description" content="The United States Senate passed the Great American Outdoors Act (S. 3422) on Wednesday, which will address deferred maintenance on our public lands and permanently fund the Land and Water Conservation Fund (LWCF).  Federal land management agencies have accumulated a deferred maintenance backlog in excess of $19 billion, while LWCF has only been funded at&hellip;" />
	<meta property="og:url" content="https://mucc.org/u-s-senate-passes-monumental-public-lands-package/" />
	<meta property="og:site_name" content="Michigan United Conservation Clubs" />
	<meta property="article:published_time" content="2020-06-17T16:47:49+00:00" />
	<meta property="og:image" content="https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage.jpg" />
	<meta property="og:image:width" content="2160" />
	<meta property="og:image:height" content="1441" />
	<meta name="twitter:card" content="summary" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://mucc.org/#website","url":"https://mucc.org/","name":"Michigan United Conservation Clubs","description":"The largest statewide conservation organization in Michigan. Its mission is to unite citizens to conserve, protect and enhance Michigan\u2019s natural resources and outdoor heritage.","potentialAction":[{"@type":"SearchAction","target":"https://mucc.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mucc.org/u-s-senate-passes-monumental-public-lands-package/#primaryimage","inLanguage":"en-US","url":"https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage.jpg","width":2160,"height":1441},{"@type":"WebPage","@id":"https://mucc.org/u-s-senate-passes-monumental-public-lands-package/#webpage","url":"https://mucc.org/u-s-senate-passes-monumental-public-lands-package/","name":"U.S. Senate Passes Monumental Public Lands Package - Michigan United Conservation Clubs","isPartOf":{"@id":"https://mucc.org/#website"},"primaryImageOfPage":{"@id":"https://mucc.org/u-s-senate-passes-monumental-public-lands-package/#primaryimage"},"datePublished":"2020-06-17T16:47:49+00:00","dateModified":"2020-06-17T16:47:49+00:00","author":{"@id":"https://mucc.org/#/schema/person/c5639d6ea1fd7424bf432426b7905ee5"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mucc.org/u-s-senate-passes-monumental-public-lands-package/"]}]},{"@type":["Person"],"@id":"https://mucc.org/#/schema/person/c5639d6ea1fd7424bf432426b7905ee5","name":"Charlie Booher","image":{"@type":"ImageObject","@id":"https://mucc.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1c2a52a19dc64b3ad457a30f2ac4516a?s=96&d=mm&r=g","caption":"Charlie Booher"},"description":"Charlie Booher is a State Conservation Policy Fellow with Michigan United Conservation Clubs."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Michigan United Conservation Clubs &raquo; Feed" href="https://mucc.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Michigan United Conservation Clubs &raquo; Comments Feed" href="https://mucc.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Michigan United Conservation Clubs &raquo; U.S. Senate Passes Monumental Public Lands Package Comments Feed" href="https://mucc.org/u-s-senate-passes-monumental-public-lands-package/feed/" />
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mucc.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://mucc.org/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://mucc.org/wp-includes/css/dist/block-library/theme.min.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='inspire-events-css'  href='https://mucc.org/wp-content/plugins/inspire-events/includes/css/main.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://mucc.org/wp-content/plugins/inspire-events/includes/css/jquery-ui/inspire/jquery-ui.min.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='jquery-ui-theme-css'  href='https://mucc.org/wp-content/plugins/inspire-events/includes/css/jquery-ui/inspire/theme.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://mucc.org/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.min.css?ver=2.3.2.5' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://mucc.org/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.7.6.3' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://mucc.org/wp-content/uploads/bb-theme/skin-5ee15a5166227.css?ver=1.7.6.3' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-ddcbcc9b9cf09a4823bb0c04322c316d-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.4.2' media='all' />
<script src='https://mucc.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://mucc.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script src='https://mucc.org/wp-includes/js/jquery/ui/selectmenu.min.js?ver=1.11.4'></script>
<script>
var NIE = {"ajaxurl":"https:\/\/mucc.org\/wp-admin\/admin-ajax.php","firstDay":"1","nie_theme":"1","nie_limit":"3","nie_limit_txt":"more ...","timeFormat":"h(:mm)A","defaultView":"month","weekends":"true","header":{"left":"prev,next today","center":"title","right":"month,basicWeek,basicDay"},"nie_qtips":"1","nie_qtips_classes":"ui-tooltip-light ui-tooltip-shadow","nie_qtips_my":"top center","nie_qtips_at":"bottom center"};
</script>
<script src='https://mucc.org/wp-content/plugins/inspire-events/includes/js/main.js?ver=1.1.0'></script>
<link rel='https://api.w.org/' href='https://mucc.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mucc.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mucc.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://mucc.org/?p=8450' />
<link rel="alternate" type="application/json+oembed" href="https://mucc.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmucc.org%2Fu-s-senate-passes-monumental-public-lands-package%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mucc.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmucc.org%2Fu-s-senate-passes-monumental-public-lands-package%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//mucc.org/?wordfence_lh=1&hid=E8676A400F20822521F6764125419E53');
</script><link rel="pingback" href="https://mucc.org/xmlrpc.php">
<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-32x32.png" sizes="32x32" />
<link rel="icon" href="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-180x180.png" />
<meta name="msapplication-TileImage" content="https://mucc.org/wp-content/uploads/2017/09/cropped-MUCC-e1510245908829-270x270.png" />
		<style id="wp-custom-css">
			@media (min-width: 600px) { 
    .neon_C_content .neoncrm-three-column .neoncrm-product-list-product { 
        width: 31%;
    }
    .neon_C_content .neoncrm-product-list.neoncrm-three-column { 
        text-align: center;
    } 
}

/*
CSS Migrated from BB theme:
*/

.z2shadow {
    text-shadow: 1px 1px #000000;   
}		</style>
		<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.3.1/css/all.css" integrity="sha384-mzrmE5qonljUremFsqc01SB46JvROS7bZs3IO2EmfFsd15uHvIt+Y8vEf7N7fWAU" crossorigin="anonymous">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.8.1/css/all.css">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.8.1/css/v4-shims.css">
<link rel="stylesheet" href="https://mucc.org/wp-content/themes/bb-inspire/style.css" /></head>
<body class="post-template-default single single-post postid-8450 single-format-standard fl-framework-bootstrap fl-preset-agloe-nature fl-full-width fl-has-sidebar fl-footer-effect fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div class="fl-page">
	<header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile"  role="banner">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-sm-12 col-md-3 fl-page-logo-wrap">
					<div class="fl-page-header-logo">
						<a href="https://mucc.org/"><img data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://mucc.org/wp-content/uploads/2017/10/wordmarkResized-1.png" data-retina="" title="" alt="Michigan United Conservation Clubs" /><meta itemprop="name" content="Michigan United Conservation Clubs" /></a>
					</div>
				</div>
				<div class="col-sm-12 col-md-9 fl-page-fixed-nav-wrap">
					<div class="fl-page-nav-wrap">
						<nav class="fl-page-nav fl-nav navbar navbar-default navbar-expand-md" aria-label="Header Menu" role="navigation">
							<button type="button" class="navbar-toggle navbar-toggler" data-toggle="collapse" data-target=".fl-page-nav-collapse">
								<span>Menu</span>
							</button>
							<div class="fl-page-nav-collapse collapse navbar-collapse">
								<ul id="menu-main-navigation" class="nav navbar-nav navbar-right menu fl-theme-menu"><li id="menu-item-1659" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1659 nav-item"><a href="https://mucc.org/about-us/" class="nav-link">About</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1670" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1670 nav-item"><a href="https://mucc.org/blog/" class="nav-link">Blog</a></li>
	<li id="menu-item-1675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1675 nav-item"><a href="https://mucc.org/financials/" class="nav-link">Membership</a></li>
	<li id="menu-item-1674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1674 nav-item"><a href="https://mucc.org/conservation-partners/" class="nav-link">Partners</a></li>
	<li id="menu-item-7231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7231 nav-item"><a href="https://p2a.co/xnhf8XJ" class="nav-link">Policy Action Center</a></li>
	<li id="menu-item-1672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1672 nav-item"><a href="https://mucc.org/staff/" class="nav-link">Staff</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
	<ul class="sub-menu">
		<li id="menu-item-5117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5117 nav-item"><a href="https://mucc.org/staff/careers/" class="nav-link">Careers</a></li>
	</ul>
</li>
	<li id="menu-item-1671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1671 nav-item"><a href="https://mucc.org/board/" class="nav-link">Board of Directors</a></li>
	<li id="menu-item-1673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1673 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/eventList.jsp" class="nav-link">Calendar</a></li>
	<li id="menu-item-4561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4561 nav-item"><a href="https://mucc.org/about-us/economic-impact-study-2019/" class="nav-link">Economic Impact Study 2019</a></li>
	<li id="menu-item-5116" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5116 nav-item"><a href="https://mucc.org/affiliated-clubs/" class="nav-link">Affiliated Clubs</a></li>
</ul>
</li>
<li id="menu-item-1660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1660 nav-item"><a href="https://mucc.org/events/" class="nav-link">Events</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1677" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1677 nav-item"><a href="https://mucc.org/mucc-annual-convention/" class="nav-link">MUCC Annual Convention</a></li>
	<li id="menu-item-1676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1676 nav-item"><a href="https://mucc.org/annual-charity-shoot/" class="nav-link">Annual Charity Shoot</a></li>
</ul>
</li>
<li id="menu-item-1661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1661 nav-item"><a href="https://mucc.org/programs/" class="nav-link">Programs</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1680" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1680 nav-item"><a href="https://mucc.org/on-the-ground/" class="nav-link">ON THE GROUND</a></li>
	<li id="menu-item-6028" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6028 nav-item"><a href="https://mucc.org/on-the-water/" class="nav-link">On The Water</a></li>
	<li id="menu-item-2512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2512 nav-item"><a href="http://www.mucccamp.org/" class="nav-link">Youth Camp</a></li>
	<li id="menu-item-1679" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1679 nav-item"><a href="https://mucc.org/cooperatives/" class="nav-link">Michigan Wildlife Cooperatives</a></li>
</ul>
</li>
<li id="menu-item-1666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1666 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Support</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1684 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC: become a member</a></li>
	<li id="menu-item-1687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1687 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Donate</a></li>
	<li id="menu-item-1683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1683 nav-item"><a href="https://mucc.org/conservation-insider-2/" class="nav-link">Conservation Insider</a></li>
	<li id="menu-item-1685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1685 nav-item"><a href="https://mucc.org/sweepstakes/" class="nav-link">SWEEPSTAKES</a></li>
</ul>
</li>
<li id="menu-item-1662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1662 nav-item"><a href="https://mucc.org/about/" class="nav-link">Media</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li id="menu-item-1664" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1664 nav-item"><a href="https://mucc.org/post-239/" class="nav-link">Michigan Out-of-Doors</a></li>
	<li id="menu-item-1665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1665 nav-item"><a href="https://mucc.org/video/" class="nav-link">Video</a></li>
</ul>
</li>
<li id="menu-item-1688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1688 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/giftstore.jsp" class="nav-link">Online Store</a></li>
<li id="menu-item-1663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC</a></li>
</ul>							</div>
						</nav>
					</div>
				</div>
			</div>
		</div>
	</div>
</header><!-- .fl-page-header-fixed -->
<div class="fl-page-bar">
	<div class="fl-page-bar-container container">
		<div class="fl-page-bar-row row">
			<div class="col-sm-6 col-md-6 text-left clearfix">	<div class="fl-social-icons">
	<a href="https://www.facebook.com/mucc1937/" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="https://twitter.com/MIOutofDoors" target="_blank" rel="noopener noreferrer"><span class="sr-only">Twitter</span><i aria-hidden="true" class="fab fa-twitter mono"></i></a><a href="www.youtube.com" target="_blank" rel="noopener noreferrer"><span class="sr-only">Youtube</span><i aria-hidden="true" class="fab fa-youtube mono"></i></a></div>
</div>			<div class="col-sm-6 col-md-6 text-right clearfix">		<nav class="top-bar-nav" aria-label="Top Bar Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" role="navigation">
			<ul id="menu-navigation" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-1667" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1667 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Donate</a></li>
<li id="menu-item-1690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1690 nav-item"><a href="https://mucc.org/about/" class="nav-link">Become a Member</a></li>
<li id="menu-item-1669" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1669 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/login.jsp" class="nav-link">Log In</a></li>
</ul></nav></div>		</div>
	</div>
</div><!-- .fl-page-bar -->
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader"  role="banner">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-md-12 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://mucc.org/" itemprop="url"><img data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://mucc.org/wp-content/uploads/2017/10/wordmarkResized-1.png" data-retina="" title="" alt="Michigan United Conservation Clubs" /><meta itemprop="name" content="Michigan United Conservation Clubs" /></a>
											</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav fl-nav navbar navbar-default navbar-expand-md" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" role="navigation">
				<button type="button" class="navbar-toggle navbar-toggler" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span>Menu</span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-main-navigation-1" class="nav navbar-nav menu fl-theme-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1659 nav-item"><a href="https://mucc.org/about-us/" class="nav-link">About</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1670 nav-item"><a href="https://mucc.org/blog/" class="nav-link">Blog</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1675 nav-item"><a href="https://mucc.org/financials/" class="nav-link">Membership</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1674 nav-item"><a href="https://mucc.org/conservation-partners/" class="nav-link">Partners</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7231 nav-item"><a href="https://p2a.co/xnhf8XJ" class="nav-link">Policy Action Center</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1672 nav-item"><a href="https://mucc.org/staff/" class="nav-link">Staff</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5117 nav-item"><a href="https://mucc.org/staff/careers/" class="nav-link">Careers</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1671 nav-item"><a href="https://mucc.org/board/" class="nav-link">Board of Directors</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1673 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/eventList.jsp" class="nav-link">Calendar</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4561 nav-item"><a href="https://mucc.org/about-us/economic-impact-study-2019/" class="nav-link">Economic Impact Study 2019</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5116 nav-item"><a href="https://mucc.org/affiliated-clubs/" class="nav-link">Affiliated Clubs</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1660 nav-item"><a href="https://mucc.org/events/" class="nav-link">Events</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1677 nav-item"><a href="https://mucc.org/mucc-annual-convention/" class="nav-link">MUCC Annual Convention</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1676 nav-item"><a href="https://mucc.org/annual-charity-shoot/" class="nav-link">Annual Charity Shoot</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1661 nav-item"><a href="https://mucc.org/programs/" class="nav-link">Programs</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1680 nav-item"><a href="https://mucc.org/on-the-ground/" class="nav-link">ON THE GROUND</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6028 nav-item"><a href="https://mucc.org/on-the-water/" class="nav-link">On The Water</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2512 nav-item"><a href="http://www.mucccamp.org/" class="nav-link">Youth Camp</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1679 nav-item"><a href="https://mucc.org/cooperatives/" class="nav-link">Michigan Wildlife Cooperatives</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1666 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Support</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1684 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC: become a member</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1687 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/donation.jsp" class="nav-link">Donate</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1683 nav-item"><a href="https://mucc.org/conservation-insider-2/" class="nav-link">Conservation Insider</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1685 nav-item"><a href="https://mucc.org/sweepstakes/" class="nav-link">SWEEPSTAKES</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1662 nav-item"><a href="https://mucc.org/about/" class="nav-link">Media</a><div class="fl-submenu-icon-wrap"><span class="fl-submenu-toggle-icon"></span></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1664 nav-item"><a href="https://mucc.org/post-239/" class="nav-link">Michigan Out-of-Doors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1665 nav-item"><a href="https://mucc.org/video/" class="nav-link">Video</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1688 nav-item"><a href="https://michiganunitedconservationclubs.z2systems.com/giftstore.jsp" class="nav-link">Online Store</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663 nav-item"><a href="https://mucc.org/about/" class="nav-link">Join MUCC</a></li>
</ul><div class="fl-page-nav-search">
	<a href="javascript:void(0);" class="fas fa-search" aria-label="Search" aria-expanded="false" aria-haspopup="true" id='flsearchform'></a>
	<form method="get" role="search" aria-label="Search" action="https://mucc.org/" title="Type and press Enter to search.">
		<input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" aria-labelledby="flsearchform" />
	</form>
</div>
				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div id="fl-main-content" class="fl-page-content" itemprop="mainContentOfPage" role="main">

		
<div class="container">
	<div class="row">

		
		<div class="fl-content fl-content-left col-md-9">
			<article class="fl-post post-8450 post type-post status-publish format-standard has-post-thumbnail hentry category-policy tag-conservation tag-habitat tag-policy tag-public-land tag-wildlife" id="fl-post-8450" itemscope itemtype="https://schema.org/BlogPosting">

					<div class="fl-post-thumb">
			<img width="1024" height="683" src="https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage-1024x683.jpg" class="attachment-large size-large wp-post-image" alt="" itemprop="image" srcset="https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage-1024x683.jpg 1024w, https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage-300x200.jpg 300w, https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage-768x512.jpg 768w, https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage-1536x1025.jpg 1536w, https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage-2048x1366.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" />		</div>
			
	<header class="fl-post-header" role="banner">
		<h1 class="fl-post-title" itemprop="headline">
			U.S. Senate Passes Monumental Public Lands Package					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://mucc.org/author/cbooher/"><span>Charlie Booher</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date">June 17, 2020</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://mucc.org/u-s-senate-passes-monumental-public-lands-package/#respond" tabindex="-1" aria-hidden="true"><span aria-label="Comments: 0">0 <i aria-hidden="true" class="fas fa-comment"></i></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://mucc.org/u-s-senate-passes-monumental-public-lands-package/" content="U.S. Senate Passes Monumental Public Lands Package" /><meta itemprop="datePublished" content="2020-06-17" /><meta itemprop="dateModified" content="2020-06-17" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Michigan United Conservation Clubs"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mucc.org/wp-content/uploads/2017/10/wordmarkResized-1.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://mucc.org/author/cbooher/" /><meta itemprop="name" content="Charlie Booher" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mucc.org/wp-content/uploads/2020/06/GAOA-Passage.jpg" /><meta itemprop="width" content="2160" /><meta itemprop="height" content="1441" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

			
			
	
	<div class="fl-post-content clearfix" itemprop="text">
		<p><span style="font-weight: 400">The United States Senate passed the Great American Outdoors Act (</span><a href="https://www.congress.gov/bill/116th-congress/senate-bill/3422" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400">S. 3422</span></a><span style="font-weight: 400">) on Wednesday, which will address deferred maintenance on our public lands and permanently fund the Land and Water Conservation Fund (LWCF). </span></p>
<p><span style="font-weight: 400">Federal land management agencies have accumulated a deferred maintenance backlog in excess of $19 billion, while LWCF has only been funded at full capacity (~$900 million) once since 1964. Deferred maintenance is considered debt on the federal balance sheets and often makes it more difficult for citizens to utilize public lands. LWCF provides funding for public land access and improvement. </span></p>
<p><span style="font-weight: 400">This bill dedicates permanent, full funding to LWCF. Further, it creates the National Parks and Public Land Legacy Restoration Fund, which will utilize up to $1.9 billion annually to improve roads, bridges, trails, campsites, boat launches and other infrastructure on federal lands in the next five years. These funds are generated from royalties paid on energy development on federal lands or waters. In passing the </span><a href="https://mucc.org/u-s-senate-takes-up-historic-public-lands-package/" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400">Great American Outdoors Act</span></a><span style="font-weight: 400"> on a vote of 73-25, the Senate made a strong commitment to invest in our outdoor economy with dedicated funds.</span></p>
<p><span style="font-weight: 400">Michigan United Conservation Clubs (MUCC) is strongly committed to maintaining and improving our public lands, and MUCC applauds the Senate’s bipartisan action through this bill, said MUCC Executive Director Amy Trotter. </span></p>
<p><span style="font-weight: 400">“The Great American Outdoors Act provides massive benefits to the parks and public lands of this country,” Trotter said. “Addressing the deferred maintenance backlog on public lands and permanent, full funding for the Land and Water Conservation Fund will help our members pursue their passions. This is a huge win for conservationists in Michigan and across the country, now it is time for the U.S. House of Representatives and President Trump to do their part in this process.” </span></p>
<p><span style="font-weight: 400">LWCF is one of the most successful conservation tools in the nation for opening access to fishing and hunting opportunities, conserving fish and wildlife habitat and supporting the outdoor recreation industry. </span></p>
<p><span style="font-weight: 400">A number of public land sites in Michigan have benefited from LWCF in the past, including the Huron, Ottawa and Hiawatha national forests, Sleeping Bear Dunes National Lakeshore and Shiawassee National Wildlife Refuge. Many thousands of acres of public land in Michigan stand to benefit from the full funding of this program now. </span></p>
<p><span style="font-weight: 400">Beyond LWCF, this bill will also address the deferred maintenance backlog on National Park Service, U.S. Forest Service, Bureau of Land Management, U.S. Fish and Wildlife Service and Bureau of Indian Education lands. According to the nonpartisan Congressional Research Service, these five agencies have a combined deferred maintenance backlog totaling more than $19 billion. The dedicated funds allotted in this bill will be divided among these agencies. The National Park Service will receive 70 percent of the funds, the Forest Service will receive 15 percent and the other three agencies will each receive 5 percent. </span></p>
<p><span style="font-weight: 400">Nationally, the outdoor recreation industry maintains more than 5.2 million American jobs and $778 billion in economic output. According to a </span><a href="https://mucc.org/about-us/economic-impact-study-2019/" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400">study commissioned by Michigan United Conservation Clubs</span></a><span style="font-weight: 400">, Michigan contributes 171,000 of those jobs and $11.2 billion of that economic activity. In funding these long lists of shovel-ready projects developed by our public land management agencies, the Great American Outdoors Act will restore and replace infrastructure, create new jobs and vitalize our robust outdoor recreation economies. </span></p>
<p><span style="font-weight: 400">The Senate held a number of procedural votes on this legislation over the last two weeks, each gathering support greater than the necessary 60-vote threshold. </span></p>
<p><span style="font-weight: 400">This legislation saw some pushback from Senators from states on the Gulf of Mexico, as these states are home to the majority of facilities used for energy resource development – the royalties from which fund the Great American Outdoors Act. These Senators showed opposition, as their states bear the environmental burdens created by offshore oil and gas development, but do not always receive a proportional share of the royalties. </span></p>
<p><span style="font-weight: 400">Other opposition came from private land advocates, as well as some who claimed that this legislation would make conservation efforts reliant on fossil fuels. </span></p>
<p><span style="font-weight: 400">This legislation still needs to be passed by the House of Representatives and signed by the president before it can be enacted. </span></p>
	</div><!-- .fl-post-content -->

	
	<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://mucc.org/category/policy/" rel="category tag">Policy</a> and tagged <a href="https://mucc.org/tag/conservation/" rel="tag">Conservation</a>, <a href="https://mucc.org/tag/habitat/" rel="tag">Habitat</a>, <a href="https://mucc.org/tag/policy/" rel="tag">policy</a>, <a href="https://mucc.org/tag/public-land/" rel="tag">Public Land</a>, <a href="https://mucc.org/tag/wildlife/" rel="tag">Wildlife</a></div></div>	<div class="fl-post-nav clearfix"><span class="fl-post-nav-prev"><a href="https://mucc.org/otw-is-cleaning-up-sault-ste-marie/" rel="prev">&larr; OTW is cleaning up Sault Ste Marie</a></span></div>	<div class="fl-author-box">
	<div class="fl-author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/1c2a52a19dc64b3ad457a30f2ac4516a?s=68&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1c2a52a19dc64b3ad457a30f2ac4516a?s=136&#038;d=mm&#038;r=g 2x' class='avatar avatar-68 photo' height='68' width='68' />	</div> <!-- /.author-avatar -->
	<div class="fl-author-description">
				<h4>About Charlie Booher</h4>
		<p>Charlie Booher is a State Conservation Policy Fellow with Michigan United Conservation Clubs.</p>
		<div class="fl-author-link">
			<a href="https://mucc.org/author/cbooher/" rel="author">
				View all posts by Charlie Booher <span class="meta-nav">&rarr;</span>			</a>
		</div> <!-- /.author-link	-->
	</div> <!-- /.author-description -->
</div> <!-- /.author-info -->

</article>
<div class="fl-comments">

	
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/u-s-senate-passes-monumental-public-lands-package/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://mucc.org/wp-comments-post.php" method="post" id="fl-comment-form" class="fl-comment-form"><label for="fl-comment">Comment</label><textarea id="fl-comment" name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea><br /><label for="fl-author">Name (required)</label>
									<input type="text" id="fl-author" name="author" class="form-control" value="" tabindex="1" aria-required="true" /><br />
<label for="fl-email">Email (will not be published) (required)</label>
									<input type="text" id="fl-email" name="email" class="form-control" value="" tabindex="2" aria-required="true" /><br />
<label for="fl-url">Website</label>
									<input type="text" id="fl-url" name="url" class="form-control" value="" tabindex="3" /><br />
<p class="form-submit"><input name="submit" type="submit" id="fl-comment-form-submit" class="btn btn-primary" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='8450' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4f446cd57b" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="45"/></p></form>	</div><!-- #respond -->
		</div>


<!-- .fl-post -->
		</div>

		<div class="fl-sidebar fl-sidebar-right fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
			</div>

	</div>
</div>

			
	</div><!-- .fl-page-content -->
		<footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		<div class="fl-page-footer">
	<div class="fl-page-footer-container container">
		<div class="fl-page-footer-row row">
			<div class="col-sm-6 col-md-6 text-left clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">Michigan United Conservation Clubs, a 501c3 nonprofit conservation organization <br>
2101 Wood St. <br>
Lansing, MI 48912<br>
517.371.1041</div></div>			<div class="col-sm-6 col-md-6 text-right clearfix">	<div class="fl-social-icons">
	<a href="https://www.facebook.com/mucc1937/" class="fa-stack icon-facebook-f" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span>
					<i aria-hidden="true" class="fas fa-circle fa-stack-2x mono"></i>
					<i aria-hidden="true" class="fab fa-facebook-f mono fa-stack-1x fa-inverse"></i>
					</a><a href="https://twitter.com/MIOutofDoors" class="fa-stack icon-twitter" target="_blank" rel="noopener noreferrer"><span class="sr-only">Twitter</span>
					<i aria-hidden="true" class="fas fa-circle fa-stack-2x mono"></i>
					<i aria-hidden="true" class="fab fa-twitter mono fa-stack-1x fa-inverse"></i>
					</a><a href="www.youtube.com" class="fa-stack icon-youtube" target="_blank" rel="noopener noreferrer"><span class="sr-only">Youtube</span>
					<i aria-hidden="true" class="fas fa-circle fa-stack-2x mono"></i>
					<i aria-hidden="true" class="fab fa-youtube mono fa-stack-1x fa-inverse"></i>
					</a></div>
</div>		</div>
	</div>
</div><!-- .fl-page-footer -->
		<div style="font-size: 11px; text-align: center; padding: 10px 0; opacity: 0.7;">
			Website powered by <a target="_blank" href="https://www.neoncrm.com/websites">Neon Inspire</a>
		</div>
	</footer>
		</div><!-- .fl-page -->
<link rel='stylesheet' id='font-awesome-5-css'  href='https://mucc.org/wp-content/plugins/bb-plugin/fonts/fontawesome/5.13.0/css/all.min.css?ver=2.3.2.5' media='all' />
<script>
var google_analytics = {"code":"UA-6089463-1","internal_code":"UA-103910486-15"};
</script>
<script src='https://mucc.org/wp-content/plugins/neoncrm-suite/js/neon-google-analytics.js?ver=5.4.2'></script>
<script>
var neoncrm_email_ajax_object = {"ajax_url":"https:\/\/mucc.org\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://mucc.org/wp-content/plugins/neoncrm-suite/js/neon-email-signup.js?ver=5.4.2'></script>
<script src='https://mucc.org/wp-content/plugins/bb-plugin/js/jquery.ba-throttle-debounce.min.js?ver=2.3.2.5'></script>
<script src='https://mucc.org/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=2.3.2.5'></script>
<script src='https://mucc.org/wp-content/plugins/bb-plugin/js/jquery.fitvids.min.js?ver=1.2'></script>
<script src='https://mucc.org/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script src='https://mucc.org/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.7.6.3'></script>
<script>
var themeopts = {"medium_breakpoint":"992","mobile_breakpoint":"768"};
</script>
<script src='https://mucc.org/wp-content/themes/bb-theme/js/theme.min.js?ver=1.7.6.3'></script>
<script src='https://mucc.org/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script async="async" src='https://mucc.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
</body>
</html>
<!-- Dynamic page generated in 1.492 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-06-17 22:40:09 -->

<!-- super cache -->